Some calls slow to complete

Incident Report for Fathom Video

Resolved

The incident is resolved.
Posted Aug 25, 2022 - 11:40 PDT

Identified

No data is lost, but calls will take longer to be available after completion.
Posted Aug 25, 2022 - 10:36 PDT