Pages slow to load or returns an error

Incident Report for Fathom Video

Resolved

This incident has been resolved.
Posted Sep 28, 2023 - 13:48 PDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 28, 2023 - 10:05 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 28, 2023 - 09:29 PDT

Investigating

We are currently investigating this issue.
Posted Sep 28, 2023 - 09:12 PDT
This incident affected: Website.